IonCube Loader is a software instrument, that's required to run files which are encoded with ionCube PHP Encoder. The aforementioned is an app which is used to make PHP code human unreadable, so as to protect it from reverse engineering and / or not authorized use. Numerous script-driven applications, in particular message boards, content management systems and e-commerce solutions are encoded with ionCube PHP Encoder, which means that when you obtain a script and you notice that ionCube is one of the web hosting environment requirements, you need to make sure that your hosting server has the instrument pre-installed. Though it is not that hard to install it if you have your own server, it is close to impossible to do that on a shared web hosting server for the reason that the PHP environment should be precompiled and all clients on the server shall be affected.
IonCube in Cloud Hosting
If you aquire a Linux cloud hosting plan through our company, it'll be set up on our tailor-made cloud hosting platform where ionCube Loader is already present, so you will not have any kind of problems to run any script app which needs the tool in order to function properly. Furthermore, we offer you a few different versions of PHP, so in case you change the version, you'll have to activate ionCube again. Our system remembers the adjustments you make, which means that if you switch back to the earlier release of PHP that was active for your account, ionCube Loader will already be turned on. The PHP version as well as the ionCube instrument can be operated from the PHP Configuration section of our Hepsia hosting Control Panel. Each adjustment that you do takes literally just a single click and it will take effect immediately.
IonCube in Semi-dedicated Servers
In case you get a semi-dedicated server plan from us, you can take advantage of any kind of script-driven application that needs ionCube Loader for the reason that the tool is available on all of the servers that are part of our state-of-the-art cloud hosting platform. In addition, we support different releases of PHP, which means that if you move from PHP 4 to 5.2 or 5.3, for example, you can enable ionCube for that particular release with only a click from your Hepsia Control Panel. Our system will remember your choice, so in case you move back to the earlier version of PHP, the tool will already be active. For more tech-savvy users, we also provide the option to pick the PHP version and if ionCube will be active or not for a specific domain without altering the settings for the whole hosting account. This can be done by putting a php.ini file inside a domain folder with a few lines of code.