PHP is among the most widely used multiparadigm programming languages. It is pretty popular since it’s free software, which you can use to develop interactive websites such as social networking websites, web shops or e-teaching websites rather than static HTML websites. A PHP module must be present on the server where a PHP-powered website is hosted so that its code can be ‘decrypted’. Since there are no license taxes for such a module and the language offers countless possibilities for the web-based apps that you create, there’re 100s of millions of PHP websites. Besides, there are a ton of open-source PHP-based scripts, which you can use for your sites without the need to possess any coding knowledge. Considering the fact that there’re different PHP versions, you should make sure that the very same version that you used whilst building your site is available on the web server as well.
PHP 4 and PHP 5 Support in Cloud Hosting
Our cloud hosting servers support different PHP versions, which suggests that your websites will work without any problem no matter if your PHP-based scripts are out of date. We know that an old website does not invariably equal a vulnerable one as you may have carried out a lot of source code modifications. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can pick which version will be enabled for your account. You can change the version with only one single click from your Hepsia hosting Control Panel and the new settings will take effect instantly. If you want to run both newer and older scripts, there’s even an option to use a different PHP version for each of your domain names simultaneously.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Even in case your sites were created with an older version of PHP, you will be able to host them in a semi-dedicated server account from us, since we support multiple versions running simultaneously on our semi-dedicated servers and each one of them can be activated for your account with no more than one click via our custom-developed Hepsia Control Panel. Apart from the newest PHP 5.5 and PHP 5.4, we also offer 5.3, 5.2 and the older PHP 4. The latter has already been abandoned by the vast majority of web hosting vendors, but we think that you shouldn’t be compelled to modify a site that took years to set up, since older scripting language syntax doesn’t automatically equal security weaknesses. Just the opposite, a well-maintained site using PHP 4 can be more secure than a mismaintained one using PHP 5. For your convenience’s sake, we will also provide you with the opportunity to set a different PHP version for each website within the account.